Halloween sale
Home - Products - Technical Service - FVDI new version installation FAQ
« Go Back

FVDI new version installation FAQ


FVDI new version installation FAQ
Some customers may meet with the installation problem,most of them are caused by the incompatibility between the software and the operation system.

kindly note:

Please connect according to the right way when you update the firmware and get authorization.
Connect the dongle to the main unit (please note not insert to the computer), then connect the unit with the computer via USB .
The normal response of the unit and the donle :
The green light on the unit would flash and the the red light of the dongle  goes on while its green light is off.

Q:What computer configuration is required for installation?
A:CPU 1.8 above ,memory >=2GB, like Dell D630 2GB (SO106)

Q:What's the best operation system for FVDI software?
A:Windows xp is the best one ,as for Windows 7 ,it's not stable.

Q:The upate failed like the picture showed,failed to connect to the server:

FVDI new version installation FAQ display 1

A:It's much probably due to the bad network,please change your network and have a try again:

FVDI new version installation FAQ display 2
Write a Review
* Rating:
    Please select rating stars.
* Your First & Last Name:
* Your E-Mail Address:
* Review Detail:
Tell us what you think about this item and share your opinions with other people. Please make sure your review focuses only on this item. All reviews are moderated and will be reviewed within two business days. Inappropriate reviews will not be posted.
After-sales questions and issues: Contact our Customer Service Department. (A customer representative will get back to you).
Please Sign In first if you want to later edit or manage reviews uploaded by yourself.


You can search Technical Service by keyword.
Bookmark It